<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://progresspond.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://progresspond.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<!-- Ads -->

			<!-- <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2779931687661495",
          enable_page_level_ads: true
     });
</script> -->


	<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/progresspond-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script> 
 








	<!-- END Ads -->
	<script>var et_site_url='https://progresspond.com';var et_post_id='160839';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v15.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>If Biden is LBJ, Trump is the Assassination Itself - Progress Pond</title>
	<meta name="description" content="Joe Biden is reminding pundits of President Lyndon Baines Johnson, but LBJ&#039;s presidency was a response to the death of JFK." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="If Biden is LBJ, Trump is the Assassination Itself - Progress Pond" />
	<meta property="og:description" content="Joe Biden is reminding pundits of President Lyndon Baines Johnson, but LBJ&#039;s presidency was a response to the death of JFK." />
	<meta property="og:url" content="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" />
	<meta property="og:site_name" content="Progress Pond" />
	<meta property="article:published_time" content="2021-03-11T17:14:00+00:00" />
	<meta property="article:modified_time" content="2021-03-11T19:21:27+00:00" />
	<meta property="og:image" content="https://progresspond.com/wp-content/uploads/2021/03/jackie-kennedy-climbs-out-the-back-of-the-limo.png" />
	<meta property="og:image:width" content="600" />
	<meta property="og:image:height" content="355" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@https://twitter.com/BooMan23" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Martin Longman">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://progresspond.com/#organization","name":"Progresspond","url":"https://progresspond.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://progresspond.com/#logo","inLanguage":"en-US","url":"https://progresspond.com/wp-content/uploads/2019/04/Pond-option2.png","width":823,"height":360,"caption":"Progresspond"},"image":{"@id":"https://progresspond.com/#logo"}},{"@type":"WebSite","@id":"https://progresspond.com/#website","url":"https://progresspond.com/","name":"Progress Pond","description":"A Welcoming Community","publisher":{"@id":"https://progresspond.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://progresspond.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#primaryimage","inLanguage":"en-US","url":"https://progresspond.com/wp-content/uploads/2021/03/jackie-kennedy-climbs-out-the-back-of-the-limo.png","width":600,"height":355},{"@type":"WebPage","@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#webpage","url":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/","name":"If Biden is LBJ, Trump is the Assassination Itself - Progress Pond","isPartOf":{"@id":"https://progresspond.com/#website"},"primaryImageOfPage":{"@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#primaryimage"},"datePublished":"2021-03-11T17:14:00+00:00","dateModified":"2021-03-11T19:21:27+00:00","description":"Joe Biden is reminding pundits of President Lyndon Baines Johnson, but LBJ's presidency was a response to the death of JFK.","breadcrumb":{"@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/"]}]},{"@type":"BreadcrumbList","@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://progresspond.com/","url":"https://progresspond.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/","url":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/","name":"If Biden is LBJ, Trump is the Assassination Itself"}}]},{"@type":"Article","@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#article","isPartOf":{"@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#webpage"},"author":{"@id":"https://progresspond.com/#/schema/person/2bf7c723090a066774beb211462c948f"},"headline":"If Biden is LBJ, Trump is the Assassination Itself","datePublished":"2021-03-11T17:14:00+00:00","dateModified":"2021-03-11T19:21:27+00:00","mainEntityOfPage":{"@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#webpage"},"commentCount":13,"publisher":{"@id":"https://progresspond.com/#organization"},"image":{"@id":"https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#primaryimage"},"keywords":"Barack Obama,Donald Trump,Jackie Kennedy,Joe Biden,John F. Kennedy,LBJ,White House","articleSection":"Slider,White House","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#respond"]}]},{"@type":"Person","@id":"https://progresspond.com/#/schema/person/2bf7c723090a066774beb211462c948f","name":"Martin Longman","image":{"@type":"ImageObject","@id":"https://progresspond.com/#personlogo","inLanguage":"en-US","url":"https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png","caption":"Martin Longman"},"description":"Martin Longman is the web editor of the Washington Monthly. He is also the founder of Booman Tribune and Progress Pond. Before joining the Monthly, Martin was a county coordinator for ACORN/Project Vote and a political consultant. He has a degree in philosophy from Western Michigan University.","sameAs":["https://twitter.com/https://twitter.com/BooMan23"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Progress Pond &raquo; Feed" href="https://progresspond.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Progress Pond &raquo; Comments Feed" href="https://progresspond.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Progress Pond &raquo; If Biden is LBJ, Trump is the Assassination Itself Comments Feed" href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/progresspond.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Booman Theme v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://progresspond.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='bp-member-block-css'  href='https://progresspond.com/wp-content/plugins/buddypress/bp-members/css/blocks/member.min.css?ver=7.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='bp-members-block-css'  href='https://progresspond.com/wp-content/plugins/buddypress/bp-members/css/blocks/members.min.css?ver=7.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='titan-adminbar-styles-css'  href='https://progresspond.com/wp-content/plugins/anti-spam/assets/css/admin-bar.css?ver=7.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://progresspond.com/wp-includes/css/dashicons.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='bp-nouveau-css'  href='https://progresspond.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/css/buddypress.min.css?ver=7.2.0' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_frontend-css'  href='https://progresspond.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=2.5.5' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css'  href='https://progresspond.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=2.5.5' type='text/css' media='print' />
<link rel='stylesheet' id='widgetopts-styles-css'  href='https://progresspond.com/wp-content/plugins/widget-options/assets/css/widget-options.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://progresspond.com/wp-content/plugins/wpdiscuz/themes/default/style.css?ver=7.1.3' type='text/css' media='all' />
<style id='wpdiscuz-frontend-css-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpdiscuz-fa-css'  href='https://progresspond.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=7.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-combo-css-css'  href='https://progresspond.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='wmu-frontend-css-css'  href='https://progresspond.com/wp-content/plugins/wpdiscuz-media-uploader/assets/css/wmu-frontend.min.css?ver=7.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='spu-public-css-css'  href='https://progresspond.com/wp-content/plugins/popups/public/assets/css/public.css?ver=1.9.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://progresspond.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://progresspond.com/wp-content/themes/Extra/style.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://progresspond.com/wp-content/themes/booman/style.css?ver=2.24' type='text/css' media='all' />
<link rel='stylesheet' id='better-image-credits-css'  href='https://progresspond.com/wp-content/plugins/better-image-credits/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='decent-comments-widget-css'  href='https://progresspond.com/wp-content/plugins/decent-comments/css/decent-comments-widget.css' type='text/css' media='all' />
<script type='text/javascript' src='https://progresspond.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/buddypress/bp-core/js/widget-members.min.js?ver=7.2.0' id='bp-widget-members-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/buddypress/bp-core/js/jquery-query.min.js?ver=7.2.0' id='bp-jquery-query-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-cookie.min.js?ver=7.2.0' id='bp-jquery-cookie-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-scroll-to.min.js?ver=7.2.0' id='bp-jquery-scroll-to-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/progresspond.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":160839,"token":"9163f93a84","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/core/admin/js/es6-promise.auto.min.js?ver=5.7' id='es6-promise-js'></script>
<script type='text/javascript' id='et-core-api-spam-recaptcha-js-extra'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"if_biden_is_lbj_trump_is_the_assassination_itself"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/core/admin/js/recaptcha.js?ver=5.7' id='et-core-api-spam-recaptcha-js'></script>
<link rel="https://api.w.org/" href="https://progresspond.com/wp-json/" /><link rel="alternate" type="application/json" href="https://progresspond.com/wp-json/wp/v2/posts/160839" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://progresspond.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://progresspond.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://progresspond.com/?p=160839' />
<link rel="alternate" type="application/json+oembed" href="https://progresspond.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://progresspond.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F&#038;format=xml" />

	<script type="text/javascript">var ajaxurl = 'https://progresspond.com/wp-admin/admin-ajax.php';</script>

<style type="text/css" id="et-bloom-custom-css">
					.et_bloom .et_bloom_optin_1 .et_bloom_form_content { background-color: #ffffff !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_container .et_bloom_form_header { background-color: #7ab53f !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_fields i { color: #3b3b3b !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_custom_field_radio i:before { background: #3b3b3b !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2, .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 span, .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_1 .et_bloom_form_container p, .et_bloom .et_bloom_optin_1 .et_bloom_form_container p span, .et_bloom .et_bloom_optin_1 .et_bloom_form_container p strong, .et_bloom .et_bloom_optin_1 .et_bloom_form_container form input, .et_bloom .et_bloom_optin_1 .et_bloom_form_container form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } 
				</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="/wp-content/uploads/2019/04/favicon.png" /><link rel="amphtml" href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/amp/"><meta name="google-site-verification" content="Wzp1EWaAkPzphpjToierrElk256m_MPzX3gVh1i_ZXY"><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://progresspond.com/wp-content/et-cache/global/et-extra-customizer-global-16154909086579.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="bp-nouveau post-template-default single single-post postid-160839 single-format-standard pmpro-body-has-access et_bloom et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css no-js">
	<div id="page-container" class="page-container">
				<!-- Header -->

		<div class="title-area">
			<div class="container">
			<a  href="https://progresspond.com/" data-fixed-height="67">
							<img style="margin: 10px;" width="150" src="/wp-content/uploads/2019/04/Pond-option2.png" alt="Progress Pond" />
			</a>
			</div>
			</div>


		<header class="header left-right">
			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="80">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-152148" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152148"><a href="/">Home</a></li>
<li id="menu-item-154125" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-154125"><a href="#">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-154134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154134"><a href="https://progresspond.com/category/elections/">Elections</a></li>
	<li id="menu-item-154133" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-154133"><a href="https://progresspond.com/category/white-house/">White House</a></li>
	<li id="menu-item-154132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154132"><a href="https://progresspond.com/category/congress/">Congress</a></li>
	<li id="menu-item-154131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154131"><a href="https://progresspond.com/category/media/">Media</a></li>
	<li id="menu-item-154130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154130"><a href="https://progresspond.com/category/culture/">Culture</a></li>
	<li id="menu-item-154129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154129"><a href="https://progresspond.com/category/environment/">Environment</a></li>
	<li id="menu-item-154128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154128"><a href="https://progresspond.com/category/health-care/">Health Care</a></li>
	<li id="menu-item-154127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154127"><a href="https://progresspond.com/category/justice/">Justice</a></li>
	<li id="menu-item-154126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154126"><a href="https://progresspond.com/category/foreign-affairs/">Foreign Affairs</a></li>
</ul>
</li>
<li id="menu-item-154368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154368"><a href="https://progresspond.com/recent-articles/">Recent Articles</a></li>
<li id="menu-item-153349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153349"><a href="https://progresspond.com/recent-comments/">Recent Comments</a></li>
<li id="menu-item-153378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153378"><a href="https://progresspond.com/faq/">FAQ</a></li>
<li id="menu-item-155791" class="login-menu-item menu-item menu-item-type-post_type menu-item-object-page menu-item-155791"><a href="https://progresspond.com/login/">Login</a></li>
<li id="menu-item-153197" class="join-us-menu-item menu-item menu-item-type-custom menu-item-object-custom menu-item-153197"><a href="/join-us/">Join Us</a></li>
<li id="menu-item-153198" class="upgrade-menu-item menu-item menu-item-type-custom menu-item-object-custom menu-item-153198"><a href="/join-us/">Upgrade</a></li>
</ul>



							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->
						</div><!-- /#et-navigation -->


							<!-- #et-info -->
	<div id="et-info">


<!-- .et-extra-social-icons -->
<ul class="et-extra-social-icons" style="">
										<li class="et-extra-social-icon facebook">
			<a href="https://www.facebook.com/DarwintheFrog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
		</li>
											<li class="et-extra-social-icon twitter">
			<a href="https://twitter.com/PondProgress" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
		</li>
																																														<li class="et-extra-social-icon instagram">
			<a href="https://www.instagram.com/progresspond/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
		</li>
																																																																																														</ul>

<!-- .et-top-search -->
<div class="et-top-search" style="">
	<form role="search" class="et-search-form" method="get" action="https://progresspond.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form></div>

<!-- cart -->
</div>

							
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>




				<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-160839" class="module single-post-module post-160839 post type-post status-publish format-standard has-post-thumbnail hentry category-slider category-white-house tag-barack-obama tag-donald-trump tag-jackie-kennedy tag-joe-biden tag-john-f-kennedy tag-lbj tag-white-house pmpro-has-access et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">If Biden is LBJ, Trump is the Assassination Itself</h1>
								<div class="post-meta vcard">
									<p>Posted by <a href="https://progresspond.com/members/booman/" class="url fn" title="Posts by Martin Longman" rel="author">Martin Longman</a> | <span class="updated">Mar 11, 2021</span> | <a href="https://progresspond.com/category/white-house/" rel="tag">White House</a> | <a class="comments-link" href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comments">10 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 5.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-5"></span>
</span></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="https://progresspond.com/wp-content/uploads/2021/03/jackie-kennedy-climbs-out-the-back-of-the-limo.png" alt="If Biden is LBJ, Trump is the Assassination Itself" />							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p class="image-credits">Image Credits: <a href="" target="_blank">Wikipedia</a>.</p>
<p>He&#8217;s been in office fewer than one hundred days, but President Joe Biden is already getting comparisons to Lyndon Baines Johnson, the 1960&#8217;s president who introduced welfare, Head Start and a government-wide war on poverty. Here&#8217;s Dylan Matthews, writing for <em><a href="https://www.vox.com/policy-and-politics/22319572/joe-biden-american-rescue-plan-war-on-poverty">Vox</a></em>:</p>
<blockquote><p>Fifty-seven years ago, a Democratic president who had a reputation as a moderate — and who had been a senator and vice president before reaching the highest office in the land — announced his administration would be waging ‘unconditional war on poverty in America.’”</p>
<p>“With Congress’s passage of the $1.9 trillion American Rescue Plan, another Democratic president with a reputation as a moderate (and who came through the Senate and the vice presidency) is putting his stamp on American policy. The Covid-19 relief bill, which passed the US House on Wednesday afternoon and is set to be signed into law by President Joe Biden on Friday, is the most far-reaching anti-poverty legislation in more than 50 years.</p></blockquote>
<p>This got me thinking. If we&#8217;re living in some kind a repeat loop of history and Biden is in the role of LBJ, doesn&#8217;t that mean that Obama was the new JFK? And what does that make Donald Trump?</p>
<p>Quite obviously, Trump is playing the role of the assassination. He&#8217;s not Lee Harvey Oswald, but the assassination itself, with all its attendant horror and cultural consequence. In the moments after it became clear that Trump had won the 2016 presidency, much of the country, and certainly the country&#8217;s establishment, was like former First Lady Jackie Kennedy desperately collecting her husband&#8217;s splattered brains off the trunk of the presidential limousine.</p>
<p>And what did the right do in response to Kennedy&#8217;s death? Didn&#8217;t they assert themselves, nominate Barry Goldwater&#8217;s proudly extremist candidacy, and initiate a conservative takeover of the Republican Party. They certainly weren&#8217;t chastened that their alarmist rhetoric about Kennedy may have had something to do with his death in Dallas. After all, a Russian defector and communist sympathizer was blamed and then murdered on national television before he could tell his side of the story.</p>
<div id="attachment_160840" style="width: 451px" class="wp-caption alignright"><img aria-describedby="caption-attachment-160840" loading="lazy" class="wp-image-160840 size-full" src="https://progresspond.com/wp-content/uploads/2021/03/JFKWanted_for_treason.jpg" alt="" width="441" height="588" border="1" srcset="https://progresspond.com/wp-content/uploads/2021/03/JFKWanted_for_treason.jpg 441w, https://progresspond.com/wp-content/uploads/2021/03/JFKWanted_for_treason-225x300.jpg 225w" sizes="(max-width: 441px) 100vw, 441px" /><p id="caption-attachment-160840" class="wp-caption-text">Handbill circulated in Dallas on November 21, 1963.</p></div>
<p>Assuming Oswald pulled the trigger, it&#8217;s still remarkable that the rhetoric circulating in Dallas in November 1963 is so familiar to our modern ears. Fear of communists became fear of Islamist terrorists and then fear of Antifa. The defense of white supremacy and anger about federal overreach is the same. Of course, Kennedy was betraying Cuba and Portugal while Obama betrayed Israel. The Christian persecution complex is unchanged. Kennedy was lax in enforcing Communist registration laws while Obama was lax on illegal immigration. Meanwhile, Obama was secretly a Kenyan Muslim while JFK had a secret first wife.</p>
<p>JFK&#8217;s death was a national trauma but also a crisis for the left. It was a surprise that LBJ pursued such a liberal agenda considering his background as a Southern senator. His decision to do so led to a complete regional realignment of American politics, as the Republicans successfully adopted a Southern Strategy. It also spurred a cultural revolution, as the way the mid-to-late 1960&#8217;s unfolded would have been impossible without the assassination.</p>
<p>I suspect the rest of this decade will be impossible explain without reference to the national convulsion represented by Trump&#8217;s four-year term in the White House.</p>
<p>I do not expect the right to moderate. I also don&#8217;t expect President Biden to behave the way he would have had he succeeded John McCain or Mitt Romney. The enormous and ambitious COVID-19 recovery act is the first indication of this, but we&#8217;ll see it again and again, as he goes bigger and bolder and more progressive than his decades-long profile in politics would have suggested.</p>
<p>I also won&#8217;t be surprised to see cultural upheavals reminiscent of the 1960&#8217;s, driven by teenagers and college students, and perhaps accompanied by a political realignment.</p>
<p>Trump wasn&#8217;t so much a president as an event, like Pearl Harbor or 9/11. This is partly because Trump barely did the job of being a president, but it&#8217;s mainly because he very nearly destroyed the country. He did his best to assassinate the legacy of President Obama, but it looks like he produced a second LBJ instead.</p>
<div class="credits-overlay" data-target=".wp-image-160840"><a href="" target="_blank">Wikipedia</a></div>
<div id='wpd-post-rating' class='wpd-not-rated'>
            <div class='wpd-rating-wrap'>
            <div class='wpd-rating-left'></div>
            <div class='wpd-rating-data'>
                <div class='wpd-rating-value'>
                    <span class='wpdrv'>5</span>
                    <span class='wpdrc'>3</span>
                    <span class='wpdrt'>votes</span></div>
                <div class='wpd-rating-title'>Article Rating</div>
                <div class='wpd-rating-stars'><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star wpd-active' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star wpd-active' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star wpd-active' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star wpd-active' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star wpd-active' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg></div><div class='wpd-rate-starts'><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg><svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M0 0h24v24H0z' fill='none'/><path class='wpd-star' d='M12 17.27L18.18 21l-1.64-7.03L22 9.24l-7.19-.61L12 2 9.19 8.63 2 9.24l5.46 4.73L5.82 21z'/><path d='M0 0h24v24H0z' fill='none'/></svg></div></div>
            <div class='wpd-rating-right'></div></div></div><span class="et_bloom_bottom_trigger"></span>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;t=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Facebook" data-network-name="facebook" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself%20https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Twitter" data-network-name="twitter" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;t=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Google +" data-network-name="googleplus" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;t=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Tumblr" data-network-name="tumblr" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;description=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself&#038;media=https://progresspond.com/wp-content/uploads/2021/03/jackie-kennedy-climbs-out-the-back-of-the-limo-150x150.png" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Pinterest" data-network-name="pinterest" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;title=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via LinkedIn" data-network-name="linkedin" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;title=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Buffer" data-network-name="buffer" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/&#038;title=If%20Biden%20is%20LBJ%2C%20Trump%20is%20the%20Assassination%20Itself" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Email" data-network-name="basic_email" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;If Biden is LBJ, Trump is the Assassination Itself&quot; via Print" data-network-name="basic_print" data-share-title="If Biden is LBJ, Trump is the Assassination Itself" data-share-url="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="160839" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #e8533b;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://progresspond.com/2021/03/10/gutless-arkansas-governor-signs-severe-abortion-ban-he-supposedly-opposes/" rel="prev"><span class="button">Previous</span><span class="title">Gutless Arkansas Governor Signs Severe Abortion Ban He Supposedly Opposes</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>
												<div class="et_extra_other_module author-box vcard">
							<div class="author-box-header">
								<h3>About The Author</h3>
							</div>
							<div class="author-box-content clearfix">
								<div class="author-box-avatar">
									<img alt='Martin Longman' src='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png' srcset='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png 2x' class='avatar avatar-170 photo' height='170' width='170' loading='lazy'/>								</div>
								<div class="author-box-description">
									<h4><a class="author-link url fn" href="https://progresspond.com/members/booman/" rel="author" title="View all posts by Martin Longman">Martin Longman</a></h4>
									<p class="note">Martin Longman is the web editor of the Washington Monthly.

He is also the founder of Booman Tribune and Progress Pond. Before joining the Monthly, Martin was a county coordinator for ACORN/Project Vote and a political consultant. He has a degree in philosophy from Western Michigan University.</p>
									<ul class="social-icons">
																					<li><a href="https://twitter.com/BooMan23" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li>
																			</ul>
								</div>
							</div>
						</div>
						
												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://progresspond.com/2007/01/09/new-white-house-counsel-you-dont-take-a-duck-to-a-cock-fight/" title="New White House Counsel &#8212; You Don&#8217;t Take a Duck to a Cock Fight" class="post-thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2019/04/White-House-440x264.jpg" alt="New White House Counsel &#8212; You Don&#8217;t Take a Duck to a Cock Fight" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://progresspond.com/2007/01/09/new-white-house-counsel-you-dont-take-a-duck-to-a-cock-fight/">New White House Counsel &#8212; You Don&#8217;t Take a Duck to a Cock Fight</a></h4>
									<p class="date"><span class="updated">January 9, 2007</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://progresspond.com/2005/03/27/white-house-easter-egg-hunt/" title="White House Easter Egg Hunt" class="post-thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2019/04/White-House-440x264.jpg" alt="White House Easter Egg Hunt" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://progresspond.com/2005/03/27/white-house-easter-egg-hunt/">White House Easter Egg Hunt</a></h4>
									<p class="date"><span class="updated">March 27, 2005</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://progresspond.com/2020/06/02/trumps-visit-to-st-johns-church-was-an-iconic-mistake/" title="Trump&#8217;s Visit to St. John&#8217;s Church Was an Iconic Mistake" class="post-thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2020/06/giantasshole-1-440x264.jpg" alt="Trump&#8217;s Visit to St. John&#8217;s Church Was an Iconic Mistake" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://progresspond.com/2020/06/02/trumps-visit-to-st-johns-church-was-an-iconic-mistake/">Trump&#8217;s Visit to St. John&#8217;s Church Was an Iconic Mistake</a></h4>
									<p class="date"><span class="updated">June 2, 2020</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://progresspond.com/2008/01/28/state-of-the-union-thread-iii/" title="State of the Union Thread III" class="post-thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2019/04/White-House-440x264.jpg" alt="State of the Union Thread III" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://progresspond.com/2008/01/28/state-of-the-union-thread-iii/">State of the Union Thread III</a></h4>
									<p class="date"><span class="updated">January 28, 2008</span></p>
								</div>
																							</div>
						</div>
										
				    <div class="wpdiscuz_top_clearing"></div>
    <div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-1 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                                                    </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://progresspond.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment" >new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="8061cdd96f" /><input type="hidden" name="_wp_http_referer" value="/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" />                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
                                </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
                            <div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
                                </div>
                </div>
                            <div class="wpd-login-to-comment">Please login to comment</div>
                                </div>
                        <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info ">
                        <span class='wpdtc' title='10'>10</span> Comments                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                    <div class="wpd-filter wpdf-attachments wpd_not_clicked" data-filter-type="attachments" wpd-tooltip="Comments with attachments">
                <i class="fas fa-photo-video"></i>
            </div>
                                        <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                        <div class="wpd-filter wpdf-sorting">
                                                                        <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc wpdiscuz-sort-button-active" data-sorting="oldest">Oldest</span>
                                                                        <i class="fas fa-sort-down"></i>
                                <div class="wpdiscuz-sort-buttons">
                                                                            <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc" data-sorting="newest">Newest</span>
                                                                                <span class="wpdiscuz-sort-button wpdiscuz-vote-sort-up" data-sorting="by_vote">Most Voted</span>
                                                                        </div>
                            </div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
                    <div class="wpd-filter-view-all">View all comments</div>
                </div>
                                <div class="wpd-thread-list">
                    <div id='wpd-comm-2243907_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/cathie-from-canada/' target='_blank' rel='noreferrer ugc'><img alt='Cathie from Canada' src='//www.gravatar.com/avatar/b781820efd5ac71f2df4207f47ffce99?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/b781820efd5ac71f2df4207f47ffce99?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243907" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/cathie-from-canada/' rel='noreferrer ugc' target='_blank'>Cathie from Canada</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 2:30 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 2:30 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=What excellent analysis! I had ne... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243907' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243907'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>What excellent analysis! I had never thought of Trump this way, but I do believe you are right. I remember the day of the Kennedy assassination &#8211; I was in Grade 9, and I will never forget the mystifying sight of an American student in our Canadian high school sobbing her heart out in the bathroom, then walking into class and the history teacher telling us what had happened in Dallas. It was almost impossible to comprehend what had happened I don&#8217;t feel there will be any significant cultural upheavals again in the 2020s like there was in the 1960s<span id='wpdiscuz-readmore-2243907_0'><span class='wpdiscuz-hellip'>&hellip;&nbsp;</span><span class='wpdiscuz-readmore' title='Read more &raquo;'>Read more &raquo;</span></span></p>
</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='4'>4</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies">
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243907_0'></div><div id='wpd-comm-2243911_2243907' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/booman/' target='_blank' rel='noreferrer ugc'><img alt='Martin Longman' src='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png' srcset='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    <div class="wpd-comment-label" wpd-tooltip="Author" wpd-tooltip-position="right">
    <span>Author</span>
</div>
    
</div>
    <div id="comment-2243911" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/booman/' rel='noreferrer ugc' target='_blank'>Martin Longman</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 4:55 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 4:55 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=People hated LBJ because he wasn&... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243911' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243911'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    Reply to&nbsp;
    <a href="#comment-2243907">
        Cathie from Canada
    </a>
</div>
    <div class="wpd-comment-text">
    <p>People hated LBJ because he wasn&#8217;t Kennedy, too. Consider how the press treated him even before Vietnam turned into a clusterfuck.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='1'>1</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243911_2243907'></div></div></div><div id='wpd-comm-2243908_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/jafnhar/' target='_blank' rel='noreferrer ugc'><img alt='jafnhar' src='//www.gravatar.com/avatar/7bc44dbcee9a52f2e80a465aa4fd10a5?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/7bc44dbcee9a52f2e80a465aa4fd10a5?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243908" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/jafnhar/' rel='noreferrer ugc' target='_blank'>jafnhar</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 2:49 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 2:49 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=That&#8217;s rather insightful, I... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243908' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243908'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>That&#8217;s rather insightful, I think. The culture of the 1960s was fueled by the demographic reality of so many young people congregating in large cities. I&#8217;m not quite sure we have that going for us in the same way. We Gen-Xers are squeezed between two larger generations, but really the Millenials are just gentle slope up on the graph in the 1980s. It&#8217;s all downhill from there in terms of number of births.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='2'>2</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies">
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243908_0'></div><div id='wpd-comm-2243912_2243908' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/booman/' target='_blank' rel='noreferrer ugc'><img alt='Martin Longman' src='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png' srcset='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    <div class="wpd-comment-label" wpd-tooltip="Author" wpd-tooltip-position="right">
    <span>Author</span>
</div>
    
</div>
    <div id="comment-2243912" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/booman/' rel='noreferrer ugc' target='_blank'>Martin Longman</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 4:59 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 4:59 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=We&#8217;re already seeing a huge... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243912' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243912'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    Reply to&nbsp;
    <a href="#comment-2243908">
        jafnhar
    </a>
</div>
    <div class="wpd-comment-text">
    <p>We&#8217;re already seeing a huge cultural change because of the emerging power of a younger more diverse population. Today&#8217;s immigration policies are yesterday&#8217;s lunch counters, at least as far as the right is concerned. And I think the young generations are as restless right now as they were in the 1950&#8217;s and early 1960&#8217;s in the lead-up to the Summer of Love. But maybe we need some technical advances to complete the picture. For example, something on a par with The Pill.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='1'>1</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies">
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243912_2243908'></div><div id='wpd-comm-2243918_2243912' class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/tom-benjamin/' target='_blank' rel='noreferrer ugc'><img alt='Tom Benjamin' src='//www.gravatar.com/avatar/6ba6641bb3c6724cb27f7bc01475ad78?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/6ba6641bb3c6724cb27f7bc01475ad78?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243918" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/tom-benjamin/' rel='noreferrer ugc' target='_blank'>Tom Benjamin</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 6:10 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 6:10 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=I think the tense is wrong here M... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243918' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243918'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    Reply to&nbsp;
    <a href="#comment-2243912">
        Martin Longman
    </a>
</div>
    <div class="wpd-comment-text">
    <p>I think the tense is wrong here Martin. I think we have already seen a huge cultural shift over the course of my lifetime and I was 13 when JFK was assassinated. The hardcore Trump base is primarily motivated because they have lost or are losing every single cultural issue fought over the past 50 years. They have won a few battles here or there but for the most part, they have lost. The Republicans won on the economic side &#8211; all their friends got far richer, and the safety net only improved with patches here or there &#8211; by<span id='wpdiscuz-readmore-2243918_2243912'><span class='wpdiscuz-hellip'>&hellip;&nbsp;</span><span class='wpdiscuz-readmore' title='Read more &raquo;'>Read more &raquo;</span></span></p>
</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like' title='0'>0</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243918_2243912'></div></div></div></div><div id='wpd-comm-2243909_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/shatner/' target='_blank' rel='noreferrer ugc'><img alt='Shatner' src='//www.gravatar.com/avatar/1ad29e8fd8f00747b71297b3b7a6b53f?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/1ad29e8fd8f00747b71297b3b7a6b53f?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243909" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/shatner/' rel='noreferrer ugc' target='_blank'>Shatner</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 3:02 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 3:02 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=Great. Next up is Nixon.
&url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243909' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243909'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>Great. Next up is Nixon.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='3'>3</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies">
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243909_0'></div><div id='wpd-comm-2243913_2243909' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/booman/' target='_blank' rel='noreferrer ugc'><img alt='Martin Longman' src='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png' srcset='https://progresspond.com/wp-content/uploads/avatars/4/5cb7b5e70662b-bpfull.png 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    <div class="wpd-comment-label" wpd-tooltip="Author" wpd-tooltip-position="right">
    <span>Author</span>
</div>
    
</div>
    <div id="comment-2243913" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/booman/' rel='noreferrer ugc' target='_blank'>Martin Longman</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 5:01 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 5:01 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=Nixon and Carter were way-station... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243913' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243913'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    Reply to&nbsp;
    <a href="#comment-2243909">
        Shatner
    </a>
</div>
    <div class="wpd-comment-text">
    <p>Nixon and Carter were way-stations in retrospect. Both more moderate than the parties they led and the direction they were going. Of course, the Dems made a course correction after the 1980&#8217;s, but I doubt the right will follow that example.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like' title='0'>0</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243913_2243909'></div></div></div><div id='wpd-comm-2243915_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/mikeinohio/' target='_blank' rel='noreferrer ugc'><img alt='MikeInOhio' src='//www.gravatar.com/avatar/8f04217b9eaedf9dada0ae41a3c0df83?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/8f04217b9eaedf9dada0ae41a3c0df83?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243915" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/mikeinohio/' rel='noreferrer ugc' target='_blank'>MikeInOhio</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 5:29 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 5:29 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=Your ability to put stuff like th... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243915' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243915'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>Your ability to put stuff like this down is what keeps me coming back here. Just how did this analogy come to you? I am genuinely curious. Like so many of us, I think about all this shit every day, but maybe I just lack the imagination, or some kind of in-born mojo, to have these kinds of light bulbs go off in my head and be able to articulate them in such a keen and concise way. </p>
<p>You make me think about things that would never occur to me on my own.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like' title='0'>0</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243915_0'></div></div><div id='wpd-comm-2243917_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/mnpundit/' target='_blank' rel='noreferrer ugc'><img alt='MNPundit' src='//www.gravatar.com/avatar/afa6c8aca5aa3f2965b1057edeba7cb5?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/afa6c8aca5aa3f2965b1057edeba7cb5?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243917" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/mnpundit/' rel='noreferrer ugc' target='_blank'>MNPundit</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 6:04 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 6:04 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=This stuff is ancient history to ... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243917' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243917'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>This stuff is ancient history to me, but Biden is governing a bit more like Bernie domestically and that&#8217;s pretty good. It&#8217;s not all good but I&#8217;m willing to work to improve where we can.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like wpd-up' title='1'>1</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243917_0'></div></div><div id='wpd-comm-2243920_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-subscriber">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://progresspond.com/members/clearskies/' target='_blank' rel='noreferrer ugc'><img alt='clearskies' src='//www.gravatar.com/avatar/49262abfcd0bc5b0b3793b5193477ab5?s=64&#038;r=g&#038;d=mm' srcset='//www.gravatar.com/avatar/49262abfcd0bc5b0b3793b5193477ab5?s=64&#038;r=g&#038;d=mm 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/></a>
</div>
    
    
</div>
    <div id="comment-2243920" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://progresspond.com/members/clearskies/' rel='noreferrer ugc' target='_blank'>clearskies</a>
</div>
    <div class="wpd-comment-date" title="March 11, 2021 7:49 pm">
    <i class='far fa-clock' aria-hidden='true'></i>
    March 11, 2021 7:49 pm
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=I agree that the public has been ... &url=https%3A%2F%2Fprogresspond.com%2F2021%2F03%2F11%2Fif-biden-is-lbj-trump-is-the-assassination-itself%2F%23comment-2243920' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='Comment Link'><i class='fas fa-link' aria-hidden='true' data-comment-url='https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243920'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>I agree that the public has been primed for progressive action by the disaster of the Trump era, similar to the public mood for broad action on the great society after the Kennedy assassination. But one big difference between now and the 60&#8217;s was that LBJ could rely on at least some republican support in Congress for his policies. The progressive wing of the republican party is extinct now, thanks to Fox news and the dumbing down of the American right. Dems have to drag every bill through congress themselves, with the R.&#8217;s pulling the other way, kicking and screaming.<span id='wpdiscuz-readmore-2243920_0'><span class='wpdiscuz-hellip'>&hellip;&nbsp;</span><span class='wpdiscuz-readmore' title='Read more &raquo;'>Read more &raquo;</span></span></p>
</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='plus' class='svg-inline--fa fa-plus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H272V64c0-17.67-14.33-32-32-32h-32c-17.67 0-32 14.33-32 32v144H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h144v144c0 17.67 14.33 32 32 32h32c17.67 0 32-14.33 32-32V304h144c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
    <div class='wpd-vote-result wpd-vote-result-like' title='0'>0</div><div class='wpd-vote-result-sep'></div><div class='wpd-vote-result wpd-vote-result-dislike' title='0'>0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden='true' focusable='false' data-prefix='fas' data-icon='minus' class='svg-inline--fa fa-minus fa-w-14' role='img' xmlns='https://www.w3.org/2000/svg' viewBox='0 0 448 512'><path d='M416 208H32c-17.67 0-32 14.33-32 32v32c0 17.67 14.33 32 32 32h384c17.67 0 32-14.33 32-32v-32c0-17.67-14.33-32-32-32z'></path></svg>
    </div>
</div>
    
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-2243920_0'></div></div>                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
        <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

<!-- Google ads  -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar (Test) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2779931687661495"
     data-ad-slot="3244976179"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>


			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="cafe_lounge_widget" class="widget_text widget et_pb_widget widget_custom_html"><h4 class="widgettitle">Discussion</h4><div class="textwidget custom-html-widget"><center><a href='https://progresspond.com/2021/03/10/midweek-cafe-and-lounge-vol-204/'><img src='/wp-content/uploads/2019/04/PP-graphic-300x170-lounge.jpg'><br></a><center></div></div> <!-- end .et_pb_widget --><div id="et_login-2" class="widget et_pb_widget widget_et_login"><h4 class="widgettitle">Login</h4>		<div class="widget_content">
			<form name="loginform" id="loginform" action="https://progresspond.com/wp-login.php" method="post">
				<ul class="widget_list">
					<li>
						<input class="input" type="text" name="log" placeholder="USERNAME">
					</li>
					<li>
						<input class="input" type="password" name="pwd" placeholder="PASSWORD">
					</li>
					<li>
						<button type="submit" class="button">Login</button>
						<a href="https://progresspond.com/wp-login.php?action=lostpassword" class="post-meta">Lost my Password</a>
					</li>
				</ul>
			</form>
		</div>
		</div> <!-- end .et_pb_widget --><div id="custom_html-6" class="widget_text widget et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><!-- Google ads  -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar (Test) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2779931687661495"
     data-ad-slot="3244976179"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <!-- end .et_pb_widget --><div id="donations-widget" class="widget_text widget et_pb_widget widget_custom_html"><h4 class="widgettitle">Donate</h4><div class="textwidget custom-html-widget"><section class="av_textblock_section ">
    <div class="avia_textblock  " itemprop="text">
        <p>Choose the option below that works best for you.</p>
    </div>
</section>


<form id="paypal-form" action="https://www.paypal.com/cgi-bin/webscr" method="post">
                <input type="hidden" name="cmd" value="_xclick">
                <input type="hidden" name="business" value="boomanllc@gmail.com">
                <input type="hidden" name="item_name" value="Booman Tribune">
                <input type="hidden" name="no_shipping" value="0">
                <input type="hidden" name="no_note" value="1">
                <input type="hidden" name="currency_code" value="USD">
                <input type="hidden" name="tax" value="0">
                <input type="hidden" name="lc" value="US">
                <input type="hidden" name="bn" value="PP-DonationsBF">
                <input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_donateCC_LG.gif" border="0" name="submit" alt="Make payments with PayPal - it's fast, free and secure!" style="    background: transparent;">
                <img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1">
                </form>


<div class="avia-button-wrap avia-button-center  "><a href="/contact/"
        class="avia-button   avia-icon_select-no avia-color-dark avia-size-x-large avia-position-center "><span
            class="avia_iconbox_title">Donate via Check</span></a></div>
            
<div class="avia-button-wrap avia-button-center  "><a href="https://cash.app/$MartinLongman" class="avia-button   avia-icon_select-no avia-color-dark avia-size-x-large avia-position-center " target="_blank" rel="noopener"><span class="avia_iconbox_title">Donate via Square Cash</span></a></div>

<div class="avia-button-wrap avia-button-center  "><a href="/join-us/"
        class="avia-button   avia-icon_select-no avia-color-dark avia-size-x-large avia-position-center "><span
            class="avia_iconbox_title">Donate via Subscription</span></a></div>


</div></div> <!-- end .et_pb_widget -->
<div id="wpp-2" class="widget et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4><!-- cached -->
<!-- WordPress Popular Posts -->

<ul class="wpp-list">
<li>
<a href="https://progresspond.com/2021/01/14/republicans-are-too-tied-to-trumpism-to-fully-renounce-trump/" class="wpp-post-title" target="_self">Republicans Are Too Tied to Trumpism to Fully Renounce Trump</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">20 comments</span> | <span class="wpp-date">posted on January 14, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/14/my-thoughts-on-the-second-impeachment-of-donald-trump/" class="wpp-post-title" target="_self">My Thoughts on the Second Impeachment of Donald Trump</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">17 comments</span> | <span class="wpp-date">posted on January 14, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/16/suddenly-fox-news-is-in-last-place/" class="wpp-post-title" target="_self">Suddenly Fox News Is In Last Place</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">7 comments</span> | <span class="wpp-date">posted on January 16, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/11/when-a-lie-gets-too-big/" class="wpp-post-title" target="_self">When A Lie Gets Too Big</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">10 comments</span> | <span class="wpp-date">posted on January 11, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/12/what-biden-can-learn-from-abraham-lincolns-inaugural-trip/" class="wpp-post-title" target="_self">What Biden Can Learn from Abraham Lincoln&#8217;s Inaugural Trip</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">6 comments</span> | <span class="wpp-date">posted on January 12, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/17/the-failed-tweaker-coup/" class="wpp-post-title" target="_self">The Failed Tweaker Coup</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">6 comments</span> | <span class="wpp-date">posted on January 17, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/16/science-is-back-baby/" class="wpp-post-title" target="_self">Science is Back, Baby!</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">5 comments</span> | <span class="wpp-date">posted on January 16, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/09/trump-did-us-a-favor/" class="wpp-post-title" target="_self">Trump Did Us a Favor</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">2 comments</span> | <span class="wpp-date">posted on January 9, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/10/theres-a-good-chance-trump-will-lose-an-impeachment-trial/" class="wpp-post-title" target="_self">There&#8217;s a Good Chance Trump Will Lose an Impeachment Trial</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">1 comment</span> | <span class="wpp-date">posted on January 10, 2021</span></span>
</li>
<li>
<a href="https://progresspond.com/2021/01/08/the-democrats-can-help-free-the-gop-from-trump/" class="wpp-post-title" target="_self">The Democrats Can Help Free the GOP from Trump</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">2 comments</span> | <span class="wpp-date">posted on January 8, 2021</span></span>
</li>
</ul>

</div> <!-- end .et_pb_widget -->
<div id="custom_html-3" class="widget_text widget et_pb_widget widget_custom_html"><h4 class="widgettitle">Blogroll</h4><div class="textwidget custom-html-widget"><p><a href="http://washingtonmonthly.com/">Washington Monthly</a></p>
<p><a href="https://washingtonmonthly.com/political-animal/">Political Animal</a></p>
<p><a href="http://eurotrib.com/">European Tribune</a></p>
<p><a href="http://alicublog.blogspot.com/">Alicublog</a></p>
<p><a href="https://www.balloon-juice.com/">Balloon Juice</a></p>
<p><a href="http://www.bradblog.com/">Brad Blog</a></p>
<p><a href="http://crookedtimber.org/">Crooked Timber</a></p>
<p><a href="https://crooksandliars.com/latest/feed">Crooks and Liars</a></p>
<p><a href="http://dailyhowler.blogspot.com/">Daily Howler</a></p>
<p><a href="http://www.dailykos.com/">Daily Kos</a></p>
<p><a href="https://elections.dailykos.com/">Daily Kos Elections</a></p>
<p><a href="http://digbysblog.blogspot.com/">Digby's Hullabaloo</a></p>
<p><a href="http://driftglass.blogspot.com/">driftglass</a></p>
<p><a href="http://www.eschatonblog.com/">Eschaton</a></p>
<p><a href="http://field-negro.blogspot.com/">field negro</a></p>
<p><a href="http://www.first-draft.com/">First Draft</a></p>
<p><a href="http://fivethirtyeight.com/">Five Thirty Eight</a></p>
<p><a href="https://hmmdaily.com/">Hmm Daily</a></p>
<p><a href="https://www.juancole.com/">Informed Comment</a></p>
<p><a href="http://www.motherjones.com/kevin-drum/">Kevin Drum</a></p>
<p><a href="https://lancemannion.typepad.com/lance_mannion/">Lance Mannion</a></p>
<p><a href="http://www.lawyersgunsmoneyblog.com/">Lawyers, Guns &amp; Money</a></p>
<p><a href="https://mahablog.com/">Mahablog</a></p>
<p><a href="https://mikethemadbiologist.com/">Mike the Mad Biologist</a></p>
<p><a href="http://nomoremister.blogspot.com/">No More Mister Nice Blog</a></p>
<p><a href="http://yastreblyansky.blogspot.com/">Rectification of Names</a></p>
<p><a href="http://upyernoz.blogspot.com/">Rubber Hose</a></p>
<p><a href="http://rudepundit.blogspot.com/">Rude Pundit</a></p>
<p><a href="http://www.scholarsandrogues.com/">Scholars and Rogues</a></p>
<p><a href="http://www.xnerg.blogspot.com/">Skippy the Bush Kangaroo</a></p>
<p><a href="https://www.patheos.com/blogs/slacktivist">Slacktivist</a></p>
<p><a href="https://smittenkitchen.com/">Smitten&nbsp;Kitchen</a></p>
<p><a href="http://www.smirkingchimp.com/">Smirking Chimp</a></p>
<p><a href="https://talkingpointsmemo.com/">Talking Points Memo</a></p>
<p><a href="http://www.unfogged.com/">Unfogged</a></p>
<p><a href="http://zandarvts.blogspot.com/">Zandar Versus The Stupid</a></p></div></div> <!-- end .et_pb_widget --><div id="nav_menu-5" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget et_pb_widget widget_nav_menu"><h4 class="widgettitle">Sections</h4><div class="menu-sections-container"><ul id="menu-sections" class="menu"><li id="menu-item-153860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153860"><a href="https://progresspond.com/category/foreign-affairs/">Foreign Affairs</a></li>
<li id="menu-item-153861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153861"><a href="https://progresspond.com/category/justice/">Justice</a></li>
<li id="menu-item-153862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153862"><a href="https://progresspond.com/category/health-care/">Health Care</a></li>
<li id="menu-item-153863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153863"><a href="https://progresspond.com/category/environment/">Environment</a></li>
<li id="menu-item-153864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153864"><a href="https://progresspond.com/category/culture/">Culture</a></li>
<li id="menu-item-153865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153865"><a href="https://progresspond.com/category/media/">Media</a></li>
<li id="menu-item-153866" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-153866"><a href="https://progresspond.com/category/white-house/">White House</a></li>
<li id="menu-item-153867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153867"><a href="https://progresspond.com/category/elections/">Elections</a></li>
</ul></div></div> <!-- end .et_pb_widget -->


		<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2779931687661495"
     data-ad-slot="2807125691"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>

	
</div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

			<div id="footer-navigator"> Go to: [ <a href="/">Homepage</a> : <a href="#"> Top of page </a> : <a href="#wc-comment-header"> Top of comments</a> ] </div>
		<footer id="footer" class="footer_columns_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="nav_menu-6" class="widget et_pb_widget widget_nav_menu"><h4 class="widgettitle"> </h4><div class="menu-sections-container"><ul id="menu-sections-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153860"><a href="https://progresspond.com/category/foreign-affairs/">Foreign Affairs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153861"><a href="https://progresspond.com/category/justice/">Justice</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153862"><a href="https://progresspond.com/category/health-care/">Health Care</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153863"><a href="https://progresspond.com/category/environment/">Environment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153864"><a href="https://progresspond.com/category/culture/">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153865"><a href="https://progresspond.com/category/media/">Media</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-153866"><a href="https://progresspond.com/category/white-house/">White House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153867"><a href="https://progresspond.com/category/elections/">Elections</a></li>
</ul></div></div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-2">
							<div id="et-recent-posts-3" class="widget et_pb_widget widget_et_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul class="widget_list">
					<li>
									<a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" title="If Biden is LBJ, Trump is the Assassination Itself" class="widget_list_thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2021/03/jackie-kennedy-climbs-out-the-back-of-the-limo-150x150.png" alt="If Biden is LBJ, Trump is the Assassination Itself" />
			</a>								<div class="post_info">
					<a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/" class="title">If Biden is LBJ, Trump is the Assassination Itself</a>
										<div class="post-meta">
						<span class="updated">Mar 11, 2021</span> | <a href="https://progresspond.com/category/white-house/" rel="tag">White House</a>					</div>
				</div>
			</li>
					<li>
									<a href="https://progresspond.com/2021/03/10/gutless-arkansas-governor-signs-severe-abortion-ban-he-supposedly-opposes/" title="Gutless Arkansas Governor Signs Severe Abortion Ban He Supposedly Opposes" class="widget_list_thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2021/03/asahutchinson-150x150.jpg" alt="Gutless Arkansas Governor Signs Severe Abortion Ban He Supposedly Opposes" />
			</a>								<div class="post_info">
					<a href="https://progresspond.com/2021/03/10/gutless-arkansas-governor-signs-severe-abortion-ban-he-supposedly-opposes/" class="title">Gutless Arkansas Governor Signs Severe Abortion Ban He Supposedly Opposes</a>
										<div class="post-meta">
						<span class="updated">Mar 10, 2021</span> | <a href="https://progresspond.com/category/health-care/" rel="tag">Health Care</a>					</div>
				</div>
			</li>
					<li>
									<a href="https://progresspond.com/2021/03/10/midweek-cafe-and-lounge-vol-204/" title="Midweek Cafe and Lounge , Vol. 204" class="widget_list_thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2019/04/PP-1280x640-lounge-150x150.jpg" alt="Midweek Cafe and Lounge , Vol. 204" />
			</a>								<div class="post_info">
					<a href="https://progresspond.com/2021/03/10/midweek-cafe-and-lounge-vol-204/" class="title">Midweek Cafe and Lounge , Vol. 204</a>
										<div class="post-meta">
						<span class="updated">Mar 10, 2021</span> | <a href="https://progresspond.com/category/froggy-bottom/cafe/" rel="tag">Cafe</a>, <a href="https://progresspond.com/category/froggy-bottom/" rel="tag">Froggy Bottom</a>, <a href="https://progresspond.com/category/froggy-bottom/lounge/" rel="tag">Lounge</a>					</div>
				</div>
			</li>
					<li>
									<a href="https://progresspond.com/2021/03/09/is-the-socialist-takeover-of-the-nevada-democratic-party-a-good-thing/" title="Is the Socialist Takeover of the Nevada Democratic Party a Good Thing?" class="widget_list_thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2020/02/harryreid-150x150.jpg" alt="Is the Socialist Takeover of the Nevada Democratic Party a Good Thing?" />
			</a>								<div class="post_info">
					<a href="https://progresspond.com/2021/03/09/is-the-socialist-takeover-of-the-nevada-democratic-party-a-good-thing/" class="title">Is the Socialist Takeover of the Nevada Democratic Party a Good Thing?</a>
										<div class="post-meta">
						<span class="updated">Mar 9, 2021</span> | <a href="https://progresspond.com/category/elections/" rel="tag">Elections</a>					</div>
				</div>
			</li>
					<li>
									<a href="https://progresspond.com/2021/03/08/for-this-week-at-least-joe-manchin-is-a-hero/" title="For This Week at Least, Joe Manchin is a Hero" class="widget_list_thumbnail">
				<img src="https://progresspond.com/wp-content/uploads/2021/02/Joe-Manchin-150x150.jpg" alt="For This Week at Least, Joe Manchin is a Hero" />
			</a>								<div class="post_info">
					<a href="https://progresspond.com/2021/03/08/for-this-week-at-least-joe-manchin-is-a-hero/" class="title">For This Week at Least, Joe Manchin is a Hero</a>
										<div class="post-meta">
						<span class="updated">Mar 8, 2021</span> | <a href="https://progresspond.com/category/health-care/" rel="tag">Health Care</a>					</div>
				</div>
			</li>
						</ul>
		</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="et-recent-comments-3" class="widget et_pb_widget widget_et_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments" class="widget_list"><li class="recentcomments"><span class="author"><a href='https://progresspond.com/members/clearskies/' rel='external nofollow ugc' class='url'>clearskies</a></span> <span class="date">March 11, 2021</span> <div class="post-title">on <a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243920">If Biden is LBJ, Trump is the Assassination Itself</a></div></li><li class="recentcomments"><span class="author"><a href='https://progresspond.com/members/tom-benjamin/' rel='external nofollow ugc' class='url'>Tom Benjamin</a></span> <span class="date">March 11, 2021</span> <div class="post-title">on <a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243918">If Biden is LBJ, Trump is the Assassination Itself</a></div></li><li class="recentcomments"><span class="author"><a href='https://progresspond.com/members/mnpundit/' rel='external nofollow ugc' class='url'>MNPundit</a></span> <span class="date">March 11, 2021</span> <div class="post-title">on <a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243917">If Biden is LBJ, Trump is the Assassination Itself</a></div></li><li class="recentcomments"><span class="author"><a href='https://progresspond.com/members/mnpundit/' rel='external nofollow ugc' class='url'>MNPundit</a></span> <span class="date">March 11, 2021</span> <div class="post-title">on <a href="https://progresspond.com/2021/03/09/is-the-socialist-takeover-of-the-nevada-democratic-party-a-good-thing/#comment-2243916">Is the Socialist Takeover of the Nevada Democratic Party a Good Thing?</a></div></li><li class="recentcomments"><span class="author"><a href='https://progresspond.com/members/mikeinohio/' rel='external nofollow ugc' class='url'>MikeInOhio</a></span> <span class="date">March 11, 2021</span> <div class="post-title">on <a href="https://progresspond.com/2021/03/11/if-biden-is-lbj-trump-is-the-assassination-itself/#comment-2243915">If Biden is LBJ, Trump is the Assassination Itself</a></div></li></ul></div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">All Rights Reserved. Designed by <a href="https://www.titrias.com">Fady S. Ghatas</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-153858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153858"><a href="https://progresspond.com/about/">About</a></li>
<li id="menu-item-153975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153975"><a href="https://progresspond.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-153859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153859"><a href="https://progresspond.com/faq/">FAQ</a></li>
<li id="menu-item-156512" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156512"><a href="https://progresspond.com/contact/">Contact Us</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/DarwintheFrog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/PondProgress" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://www.instagram.com/progresspond/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
			<!-- Memberships powered by Paid Memberships Pro v2.5.5.
 -->
	<a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-bubble-wrapper'><span id='wpd-bubble-all-comments-count' title='10'>10</span><div id='wpd-bubble-count'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-count-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-count-second' d='M0 0h24v24H0z' /></svg><span class='wpd-new-comments-count'>0</span></div><div id='wpd-bubble'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-plus-first' d='M19 13h-6v6h-2v-6H5v-2h6V5h2v6h6v2z'/><path class='wpd-bubble-plus-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-add-message'>Would love your thoughts, please comment.<span id='wpd-bubble-add-message-close'><a href='#'>x</a></span></div></div><div id='wpd-bubble-notification'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-notification-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-notification-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-notification-message'><div id='wpd-bubble-author'><div><span id='wpd-bubble-author-avatar'></span><span id='wpd-bubble-author-name'></span><span id='wpd-bubble-comment-date'>(<span class='wpd-bubble-spans'></span>)</span></div><span id='wpd-bubble-comment-close'><a href='#'>x</a></span></div><div id='wpd-bubble-comment'><span id='wpd-bubble-comment-text'></span><span id='wpd-bubble-comment-reply-link'>| <a href='#'>Reply</a></span></div></div></div></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><div class="et_bloom_popup et_bloom_optin et_bloom_resize et_bloom_optin_1 et_bloom_scroll et_bloom_hide_mobile_optin et_bloom_auto_close" data-cookie_duration="15" data-scroll_pos="50">
							<div class="et_bloom_form_container et_bloom_popup_container et_bloom_form_bottom et_bloom_rounded et_bloom_form_text_light et_bloom_animation_fadein">
								
			<div class="et_bloom_form_container_wrapper clearfix">
				<div class="et_bloom_header_outer">
					<div class="et_bloom_form_header split et_bloom_header_text_light">
						<img src="/wp-content/plugins/bloom/images/premade-image-13.png" alt="Subscribe Now" class=" et_bloom_image_slideup et_bloom_image">
						<div class="et_bloom_form_text">
						<h2>Subscribe Now</h2><p>Join our users to read our prime articles</p>
					</div>
						
					</div>
				</div>
				<div class="et_bloom_form_content et_bloom_1_field et_bloom_bottom_inline et_bloom_custom_html_form" data-optin_id="optin_1" data-service="custom_form" data-list_id="custom_form" data-page_id="160839" data-account="custom_form">
					<form method="post" class="clearfix">
						<div class="et_bloom_fields">
							
							<p class="et_bloom_popup_input et_bloom_subscribe_email">
								<input placeholder="Email">
							</p>
							<button data-optin_id="optin_1" data-service="mailchimp" data-list_id="bd042947a6" data-page_id="152130" data-account="BooMan Media LLC" data-ip_address="true" class="et_bloom_submit_subscription" style="width:17%;">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_light">Subscribe!</span>
							</button>							
<a href="/join-us" style="
    display: inline-block;
    background: #7ab53f;
    /* float: right; */
    border-radius: 3px !important;
    padding: 12px;
    font-size: 14px;
    font-family: 'Open Sans', sans-serif;
    text-transform: uppercase;
    letter-spacing: 1px;
    font-weight: 600;
">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_light">Join Us</span>
							</a>
						</div>
					</form>
					<div class="et_bloom_success_container">
						<span class="et_bloom_success_checkmark"></span>
					</div>
					<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
					
				</div>
			</div>
			<span class="et_bloom_close_button"></span>
							</div>
						</div>	<script type="text/javascript">
			</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-59430067-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-59430067-1');
</script>
<link crossorigin="anonymous" rel='stylesheet' id='et-gf-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_bloom-css-css'  href='https://progresspond.com/wp-content/plugins/bloom/css/style.css?ver=1.3.11' type='text/css' media='all' />
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/anti-spam/assets/js/anti-spam.js?ver=7.2.5' id='anti-spam-script-js'></script>
<script type='text/javascript' id='bp-nouveau-js-extra'>
/* <![CDATA[ */
var BP_Nouveau = {"ajaxurl":"https:\/\/progresspond.com\/wp-admin\/admin-ajax.php","confirm":"Are you sure?","show_x_comments":"Show all %d comments","unsaved_changes":"Your profile has unsaved changes. If you leave the page, the changes will be lost.","object_nav_parent":"#buddypress","objects":{"0":"activity","1":"members","3":"blogs","4":"xprofile","6":"messages","7":"settings","8":"notifications"},"nonces":{"activity":"a6fc256e40","members":"50337f3af4","blogs":"9fa5cc6a35","xprofile":"ea1fe52781","messages":"42916a4dce","settings":"0713dc02a6","notifications":"b96bfed046"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/js/buddypress-nouveau.min.js?ver=7.2.0' id='bp-nouveau-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-includes/js/comment-reply.min.js?ver=5.7' id='comment-reply-js'></script>
<script type='text/javascript' id='wpdiscuz-combo-js-js-extra'>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</script>
<script type='text/javascript' id='wpdiscuz-combo-js-js-before'>
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        maxcount : 0,
        mincount : 1,
        },
		        },
        placeholder: "Join the discussion",
        theme: 'snow',
        debug: 'error'
        };
		
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js?ver=7.1.3' id='wpdiscuz-combo-js-js'></script>
<script type='text/javascript' id='wmu-frontend-js-js-extra'>
/* <![CDATA[ */
var wmuJsObj = {"wmuVersion":"7.0.7","wmuMaxFileCount":"3","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuPhraseImageSizesError":"Size restriction, try uploading an image with smaller width\/height","wmuLazyLoadImages":"1","wmuSecurity":"bdfa6152ae","wmuIconVideo":"https:\/\/progresspond.com\/wp-content\/plugins\/wpdiscuz-media-uploader\/assets\/img\/file-icons\/video-audio-type.png","wmuIconFile":"https:\/\/progresspond.com\/wp-content\/plugins\/wpdiscuz-media-uploader\/assets\/img\/file-icons\/file-type.png","wmuKeyVideos":"videos","wmuKeyFiles":"files"};
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/wpdiscuz-media-uploader/assets/js/wmu-frontend.min.js?ver=7.0.7' id='wmu-frontend-js-js'></script>
<script type='text/javascript' id='spu-public-js-extra'>
/* <![CDATA[ */
var spuvar = {"is_admin":"","disable_style":"","ajax_mode":"","ajax_url":"https:\/\/progresspond.com\/wp-admin\/admin-ajax.php","ajax_mode_url":"https:\/\/progresspond.com\/?spu_action=spu_load","pid":"160839","is_front_page":"","is_category":"","site_url":"https:\/\/progresspond.com","is_archive":"","is_search":"","is_preview":"","seconds_confirmation_close":"5"};
var spuvar_social = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/popups/public/assets/js/public.js?ver=1.9.3.8' id='spu-public-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/progresspond.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/progresspond.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"d2c69932ef","timeline_nonce":"9f86815705","blog_feed_nonce":"7f06eb2d52","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/progresspond.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/progresspond.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/progresspond.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"597db92f6f","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"9e8d417d1e","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"160839","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.24' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/better-image-credits/script.js?ver=1.0' id='better-image-credits-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/core/admin/js/common.js?ver=4.6.4' id='et-core-common-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/js/jquery.uniform.min.js?ver=1.3.11' id='et_bloom-uniform-js-js'></script>
<script type='text/javascript' id='et_bloom-custom-js-js-extra'>
/* <![CDATA[ */
var bloomSettings = {"ajaxurl":"https:\/\/progresspond.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/progresspond.com\/2021\/03\/11\/if-biden-is-lbj-trump-is-the-assassination-itself\/","stats_nonce":"6b05aee4be","subscribe_nonce":"8523051d77","is_user_logged_in":"not_logged"};
/* ]]> */
</script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/js/custom.js?ver=1.3.11' id='et_bloom-custom-js-js'></script>
<script type='text/javascript' src='https://progresspond.com/wp-content/plugins/bloom/js/idle-timer.min.js?ver=1.3.11' id='et_bloom-idle-timer-js-js'></script>

	<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

<script>
setTimeout(function () {
    jQuery(".wpdiscuz-embed-wrapper .fluid-width-video-wrapper").removeClass("fluid-width-video-wrapper").removeAttr("style");
}, 500);
</script>

</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 

Served from: progresspond.com @ 2021-03-11 19:53:58 by W3 Total Cache
-->